Browsers supported on the internet banking portal

 In Help Centre, Link, Retro

Only the following browsers support the latest version of TLS 1.2 which is secure, from June 10th 2016

  • Chrome – v30
  • Firefox – v27
  • Internet Explorer – v11
  • Opera – v17
  • Safari – v5 on iOS and v7 on OS X
Contact Us

Being such a diverse company, AFG has a range of different divisions. Send through a quick enquiry and we'll be touch with you soon.

Not readable? Change text. captcha txt

Start typing and press Enter to search